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Tekla Structures includes a command to create a Web model. You can open a 
web model by means of an internet browser or the Tekla Structures Model 
Reviewer. So you don’t need the Tekla Structures program to view the model. 
This is very handy if you want to show your model to e.g. a builder or a cus-
tomer, etc.

Conditions
You can open web models in two ways, using:

1. Any internet browser including Active X, such as Internet Explorer ver-
sion 6.0 or higher, or Maxthon), Internet Explorer will usually be installed 
on a PC. To check if IE version 6.0 is installed on your PC, you do next:

Open the Internet Explorer

In the pull-down menu, go to Help > About Internet Explorer

If you have not installed IE version 6.0 on your computer, please update 
your Internet Explorer version, go to www.microsoft.com.
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2. Tekla Structures Model Reviewer, you can install the Model Reviewer by 
clicking or the link below:

http://www.construsoft.com/home.php?lang=nl

Click on the next image:

or click on the link below:

http://www.tekla.com/international/solutions/building-construction/Pages/
web-models-model-reviewer.aspx

Click on the button Free Download, the Tekla Structures Model Reviewer 
will be installed on your PC, a shortcut will be created automatically in the 
Windows Start menu in Tekla Structures.

What is the main difference between these two ways of viewing web models?

The Tekla Structures Model Reviewer includes an additional functionality, the 
so-called Reviewer part to add markups and descriptions, this part is not included 
in any internet browser.

Prerequisites for the Tekla Structures Model Reviewer installa-
tion:

• .NET Framework 3.0

To download the .NET Framework 3.0 installation, go to 
http://www.microsoft.com.

Windows Vista: .NET Framework 3.0 is installed on the 
computer but it may have been disabled. To activate it, go 
to Windows Control panel > Programs and Features > Turn 
Windows features on or off.

• .NET Framework 2.0

• Visual C++ Runtime Libraries (x86)

• Visual C++ SP1 (x86)
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Create a web model
To create a web model, you do next:

1. In the pull-menu, go to File > Publish as Web page... or click on the icon, 
the following dialog box appears:

2. You can now select what you want to publish, either the entire model or 
selected parts

3. Now select the type of web page:

Do not change the lines <Page title>, <Template> and <Filename>.

XML No bolts are published in the web model, tooltips 
will be displayed.

Solid Parts and bolts are published in the web model.
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4. You can select the kind of tooltip you wish to have in a published Web 
Viewer model in the dropdown list Tooltip in Web Viewer.

For this, several tooltip templates are used, you can add new templates to 
enable better communication between project participants.

Use the Template Editor to define the templates and save the templates in the 
folder ..:\environments\netherlands_enu\tem-
plate\tooltips. In the accompanying *.ini file you can establish the 
name as it will be shown in the dropdown list (1).

A preview field shows what a tooltip will look like (2):

The tooltip will be displayed in the web model:
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5. Select a checkbox at <Open in browser> to open the web model directly 
after it is created (Note: the condition is IE 6.0)

6. Click <Publish>, the web model is now getting created

A Tekla Viewer appears in the Task manager on your monitor, next click the 
Tekla Web Viewer to publish the web model.

In case a web model won’t open, import the created web model 
once as a reference model in your current model. If this is not 
possible, check your current model again.

Also the pathname of the web model is restricted to a limited 
number of characters!
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Using an internet browser for a web model
Once you have created a web model, this web model is stored by default in the 
current model folder. The folder PublicWeb is added. This folder contains the 
file index.html.

Handling named views
When you send a web model to a builder or customer, sometimes it is necessary 
that the customer has to take a look at some named views from a published 
model. This can be indicated in the e-mail, but the following method is easier:

1. Open the published model

2. Zoom in on the part of the model from which you want to create the view

3. Right-click and select Copy location or <Ctrl> + C

4. Create a new file in any text editor, for example Notepad

Double-click this file to open 
the Web model.
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5. Paste or <Ctrl> + V:

The default name for the view is xyz

6. To change it, replace the text xyz with the view name that you want to use. 
e.g. “Detail A”. Note: the name starts with a letter!

7. Now copy the updated location information to the published model. For this, 
select all the text in the text editor

8. Click right mouse and select Copy or <Ctrl> + C

9. Go back to the WebViewer

10. Click right mouse on the model and select Paste or <Ctrl> + V

The view name appears on the Named views dropdown list:

Repeat these steps as many times as necessary. In the web viewer, you will see 
that the viewpoint automatically changes if you select another viewpoint!
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Hide objects
Use the mouse wheel to hide and unhide objects:

• To hide objects, move the cursor over the objects, hold down the 
<Ctrl> key and scroll forwards (or press the Page Up key).

• To unhide object, move the cursor over the hidden objects, hold down 
the <Ctrl> key and scroll backwards (or press the Page Down key).

• Press the Esc key to show all objects.

Set clip planes

Web Viewer does not save named views with the published 
model. But, you can save the text file that contains the location 
information, then cut and paste the text to the published model 
in Web Viewer the next time you want to use the view.

To create a clip 
plane, click shortcut 
p, and select a part 
in the web viewer 
model:
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To select the clip 
plane, click the 
scissor symbol:
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Move the clip plane by 
dragging the scissor sym-
bol.

You can change the 
location of the symbol by 
holding down the 
<Shift> key and moving 
the symbol.

Select a clip plane and 
press the space bar to 
jump between clip 
planes.
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Tool tips
To view the part name, position and material, move the cursor over the part:

Full content rendering
To handle large models faster, disable full content rendering:

• Right-click and select Disable full content rendering from the 
popup menu.

• To enable full content rendering, select Enable full content render-
ing from the popup menu.

Pan
Shortcut for Pan command is n.

Rotate
Shortcut for Rotate command is f.

The tooltips are only visible in case the model was published as 
XML file.
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Fly
Shortcut for Fly command is f.

Center
Shortcut for Center command is c.

Home
Shortcut for Home command is home.

Snapshot to clipboard
To copy a snapshot to the Clipboard. Shortcut for the command Snapshot to 
clipboard is b.

Change to perspective / orthogonal
Shortcut for the command Change to perspective is l. Shortcut for the command 
Change to orthogonal is o. With this you can switch between the two 
commands.

Background color
To set the background color. You can select Black, Blue and White.

Presentation
To set the representation of the profiles. You can select Wire frame (<Ctrl> + 
1), Shaded wireframe (<Ctrl> + 2) en Rendered (<Ctrl> + 3).
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Sending a web model
Sending a web model to e.g. a builder or an architect can be done very easily.

Step plan 1. Go to the model folder and zip the complete folder Publicweb by means of 
e.g. Winzip

2. You can now send this *.zip file by e-mail, for instance

3. The receiver must store the *.zip file, which is included as a subject in the e-
mail, on e.g. the Desktop

4. Extract the *.zip file

5. Double-click on the file index.html to open the web model.

Never try to open a web model while it is in the *.zip file or in 
the e-mail, this won’t work!
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Notes
• In case you cannot open a web model, go to http://www.constru-

soft.com/tekla/web_models.php and click one of the following pic-
tures:

• Now open a Web viewer models. Close this web model and open a 
local stored web model.

• Always store Web models on your local drive on the PC, not on any 
location on the network (except internet servers, see also the last 
note), to make sure that you can always open a Web model

• When the Internet Explorer crashes while opening a web model, 
there are incorrect profile cross sections in the model. This means 
that there are profiles used in the model containing incorrect cross 
sections like self defined cross sections. To check if these cross sec-
tions are incorrect, create a new web model of selected parts without 
the parts which possibly contain these incorrect cross sections

• When you copy the folder Publicweb to a internet server, so that 
everybody can view your web models online, the first time you visit 
this site, a program will be installed our your computer to enable 
viewing such models. The folder ‘dll’ on the internet server must 
contain the file zkitlib.dll. When customers inform you about the fact 
that they cannot view web models, make sure that the file zkitlib.dll 
is uploaded correctly. (the size of this file on the server is not 0 kB)
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Using the Tekla Structures Model Reviewer for a 
web model

Introduction
Tekla Structures Model Reviewer is a Tekla Web Viewer based application for 
contractors, fabricators, architects, engineers, and erectors.

With Tekla Structures Model Reviewer you can send models more easily, you 
can create comments and markups to the model, and you can easily create project 
presentations with predefined views to different areas of the project.

With Tekla Structures Model Reviewer, you can: 

• Easily pan, rotate, zoom, and fly in the model as you do in an internet 
browser, see for more information chapter Hide objects (p. 8) up to 
and including Presentation (p. 12).

• Use markup tools to quickly highlight specific areas of the project, or 
fly through a set of locations so that your audience can quickly get an 
understanding of the whole project

• Create markups with descriptions

• Use clip planes to slice your project to provide a better view in the 
difficult areas in the model

• Send models easily to other parties

• Take screenshots from the model

• Change the colors of the model to see the structures better
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Opening a web model
Opening a web model in the Tekla Structures Model Reviewer:

1. To start the application, go to Windows Start > Tekla Structures > Tekla 
Structures Model Reviewer.

2. Browse for the published model file (.wmr, .xml, or .zsol file) and open it.

XML, a web model exported to an XML file, see also Create a web model 
(p. 3)

ZSOL, a web model exported as a SOLID, see also Create a web model 
(p. 3)

WMR, web model which already has been opened in the Tekla Structures 
Model Reviewer and to which some markups have been added. These mark-
ups can only be added and viewed by using the Tekla Structures Model 
Reviewer.

When you save a web model and the markups in the Tekla Structures Model 
Reviewer, the file is saved in .wmr format.

In case the pull-down menus are not displayed in the Tekla 
Structures Model Reviewer, press the Alt-button once.
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User interface
The Tekla Structures Model Reviewer user interface is divided into three differ-
ent areas:

Menu bar and toolbar: Use the menu bar and toolbar for navi-
gating in the model, creating markups in the model and managing 
the model.

Model workspace: Use the commands on the Navigate menu for 
moving the model, or right-click in the model workspace to dis-
play the pop-up menu which contains the navigation commands 
as well as additional model workspace settings.

Markup view list: Use the markup view list for managing the 
markups, checking the type of the markups and adding descrip-
tions for the markups.
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Creating markups
You can create markups, for example, for reviewing or commenting purposes. 
For meeting purposes you can easily create a presentation where you use the 
markups for marking and showing different locations in the model.

1. Zoom in the model to the area or part of the model you want to mark with a 
markup.

2. Select one of the drawing tools, for example, Cloud.

A new markup is created to the markup view list.

You can now add a cloud to the area you zoomed, or you can add it later.

3. Select the type of the markup from the Type dropdown list, for example, 
For Review.

The symbol in the markup view list changes according to the type of the 
markup.

4. Add any additional information to the Description field.

You can play all the Location type markups one by one as a seamless presenta-
tion by clicking the Play button.

If you want to add a redlining to a markup, select the markup and an appropriate 
redlining tool and add the redlining to the model. 

If you want to delete parts of the redlining, use the Eraser tool.
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Sharing the model
You have several options how to share the Tekla Web Viewer model. The .wmr 
files are small and therefore easy to share.

Sending the model via e-mail
You can send the model in .wmr format as an e-mail attachment

1. Go to File > Attach to Email….

An e-mail message that includes the attached model in .wmr format opens in 
the Tekla Structures Model Reviewer.

2. Fill in the needed information and send the e-mail.

The receiver needs to save the *.wmr file, included as an attachment in the e-
mail, on the hard disk, for example on the desktop.

Sharing the model using a network drive
You can share the model using a network drive. People who have access to the 
same network drive can directly view and modify the same file and share com-
ments, without sending the file anywhere.

Sharing the model on the Internet
If you want to share your models on the Internet, you can publish the models as 
web pages or as .wmr files. These models can be opened by clicking the address 
link or by using the Open command.

When you open a model from a web page, you are asked to save a local copy of 
the file for commenting. After commenting the model, the file can be sent back 
to the owner of the model. 

If you want to create a link to your model, the address of the web page or net-
work drive is composed the following way: 

installation path + ?open= + model path.

Example http://www.tekla.com/ModelReviewer/ModelReviewer.application?open=http://
www.yourcompany.com/yourmodel.wmr

Never try to open a web model while it is in the *.zip file or in 
the e-mail, this won’t work!
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